Jump to content
dsteodoro

Proyecto. Carril para macro programable.

Publicaciones recomendadas

Por otro lado, en el archivo fritzing que adjunto viene el diseño de la "placa base" que yo he usado para los montajes que he hecho. Las placas las pedía en https://aisler.net y las envían en paquetes de 3. Sale por unos 25€ las tres placas con envío incluido. La calidad de construcción es simplemente excelente y simplifica enormemente el proceso de montaje de la electrónica.

 

Solo tenéis que daros de alta en la web de Aisler, crear un nuevo proyecto, subir el archivo .fzz completo y listo. Ya entonces decidís si queréis la placa o no. En la web se muestra como va a quedar y podéis subir revisiones o cambios cada vez que queráis. 

 

El soporte de esta web es también muy bueno. Cualquier duda o pregunta la responden de inmediato.

 

Le he dado un repasito al diseño de la placa para poner algunas descripciones y he subido la versión actualizada. Con esto ya no debe haber ningún problema si decidís pedirla.

 

Como he indicado en el hilo principal, para el que se anime a pedir la placa, recordad que siempre debe usar zócalos para montar el arduino nano, el driver del motor y los optoacopladores. De esta forma si algún componente falla es muy fácil sustituirlo.

 

Saludos,
Daniel

Editado por dsteodoro

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola Daniel, lo de """fritzing""" me parecía una cosa para gente más entendida que yo, pues el inglés se me resiste y tampoco soy muy ducho en andar por las webs extranjeras.... pero he seguido tu consejo y he visto que es una gozada y se trata de quitarle el miedo, la pena es que ya me he pegado un curro de la leche en hacer el circuito impreso. La verdad es que pensaba que la circuitería impresa, habría que pedir cantidades mínimas exageradas y el coste no compensaría...... pero no es así, he pedido las tres plaquitas, como tú bien dices, por un precio muy razonable.

 

Por otra parte, esto puede servir para "alipende", el comportamiento del Arduino con batería, no hace saltar "pin digital 2" y con alimentador a red sí. Pero efectivamente al colocar las resistencias ya no sale "pin digital 2" ni con batería ni con alimentador.

 

Alipende, pruébalo con las resistencias colocadas y te desaparecerá el problema.

 

Seguimos en contacto.

 

Un saludo.

Editado por Koldo A

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Está claro que tras el tiempo transcurrido la controladora SBB gana en usuarios y goza de buena salud, sin embargo quería preguntar si sería posible aumentar los micropasos que actualmente admite la controladora (128) y llegar a los 256.

El motivo por el cual hago la consulta, es que tengo una controladora (TMC2130)  que según las revisiones que he mirado tiene características muy superiores y especialmente aumenta la precisión, evitando pérdidas de paso, que la DRV8825 que actualmente tengo instalada en la SBB, pero no tengo forma de probar si esto es así.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola.

Llevo la intemerata con el ajuste del motor paso apaso con el controlador y ya apunto de tirar la toalla. El caso es que el motor cuando le doy para adelante y para atrás, con el menú en "Fija Ini:" el motor se pone a temblar pero no va ni para adelante ni para atrás. Cuando le doy a la secuencia de fotos en el programa, por defecto, después de resetearlo, consigo que se mueva pero lo mismo avanza que retrocede y además no siempre se mueve con el mismo ángulo ¿es muy crítico el ajuste del controlador del motor? ¿da mucha guerra esto de la calibración, o hay alguna fórmula mágica?

 

Saludos.

 

Koldo

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Me da la sensación que no has conectado bien el motor. Prueba a intercambiar 2 hilos. Si no atinas a la primera, identifica las dos bobinas y asegúrate de que estén bien conectadas al driver.

 

Saludos

 

Enviado desde mi MI MAX mediante Tapatalk

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Me da la sensación que no has conectado bien el motor. Prueba a intercambiar 2 hilos. Si no atinas a la primera, identifica las dos bobinas y asegúrate de que estén bien conectadas al driver.

 

Saludos

 

Enviado desde mi MI MAX mediante Tapatalk

Hola Daniel, tú siempre tan atento. Una vez más tienes la razón. por una parte confié en el esquema y el driver pero claro Muphy estaba escondido y actuó. El driver no tiene las patas como en el esquema y conecté pensando que era así y los cables del motor tampoco salen como los del esquema............ buff!!! vaya liada......... total que siguiendo tus consejos y pensando que era cosa de los cables los solté y empecé de cero identificando las bobinas y las patillas del driver, que esa es otra.... pensaba que las bobinas eran 1 y 2 pero eran A y B por lo del 1A, 2A, 1B y 2B.

Total que mil piruetas y ahora parece que funciona estupendamente.

 

Gracias una vez más, Daniel y un saludo.

 

Según vaya progresando os iré comentando, que aunque parezca que ya está todavía saldrán pegas, je, je...

 

Koldo

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola.

Llevo la intemerata con el ajuste del motor paso apaso con el controlador y ya apunto de tirar la toalla. El caso es que el motor cuando le doy para adelante y para atrás, con el menú en "Fija Ini:" el motor se pone a temblar pero no va ni para adelante ni para atrás. Cuando le doy a la secuencia de fotos en el programa, por defecto, después de resetearlo, consigo que se mueva pero lo mismo avanza que retrocede y además no siempre se mueve con el mismo ángulo ¿es muy crítico el ajuste del controlador del motor? ¿da mucha guerra esto de la calibración, o hay alguna fórmula mágica?

 

Saludos.

 

Koldo

 

 

 

Buenas Koldo A:

Para calibrar el driver este vídeo a mi me ayudó.-

 

 

Lo único que es del A4988, pero la fórmula es la misma, solo hay que cambiar en la fórmula el “8” por un “5”.

Espero que te sirva de ayuda.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Buenas Koldo A:

Para calibrar el driver este vídeo a mi me ayudó.-

 

 

Lo único que es del A4988, pero la fórmula es la misma, solo hay que cambiar en la fórmula el “8” por un “5”.

Espero que te sirva de ayuda.

...me lo guardo, lo veré con detenimiento....

 

Un saludo y gracias.

 

 

Koldo

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola compañeros.

La pregunta es sobre las 3 bases RCA que hay que colocar... una para los fines de carrera FC, otra ED1 y la otra ED2.

Segun lo que entiendo por el esquema, los RCA no se podrían colocar sobre un metal conductor (aluminio) sino que deverían ir aislados ya que si no, se produciría un corto ¿no?

 

O sea que al centro de los RCA, llevaría la conexión del Arduino y al exterior del RCA llevaría un +5v. en el caso de los fines de carrera FC y ED1 y en el caso de ED2 llevaría el exterior del RCA a masa. Por lo que entiendo que el sensor exterior funcionaría a modo de interruptor, conectando exterior e interior del RCA ¿no?

 

Otra duda que me surge es porqué ED1 no lleva una resistencia de 1K

 

Y la última es si los fines de carrera se colocan en paralelo, con contacto normalmente abierto

 

Un saludo y gracias por la comprensión, espero no ser muy pesadito, je, je....

Koldo

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web
En 16/12/2018 a las 11:24, Koldo A dijo:

Ya me han llegado las placas.......... y con una calidad a tope

 

DSC04899 RR placas ci.jpg

Cuenta que tal te ha ido ahora usando las placas. Como veras, queda todo mucho mas recogido y el montaje es mucho mas fácil.

Para las conexiones externas (lcd, joystick, motor, ...) yo he usado los "kits" de cables que venden para baterías LiPo y de esa forma puedo poner y quitar los elementos "externos" de una forma fácil.

https://www.banggood.com/es/10Pairs-22AWG-100mm-2S-3S-4S-5S-6S-LiPo-Battery-Male-Female-Connector-Plug-Balance-Cable-p-1102078.html?ID=47895&cur_warehouse=CN

Por ejemplo, para la pantalla y el motor que usan 4 hilos haría falta el cable 3S (3 positivos + 1 comun) y para el Joystick que usa 5 hilos un 4S.

Saludos,
Daniel

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Crear una cuenta o conéctate para comentar

Tienes que ser miembro para dejar un comentario

Crear una cuenta

Regístrese para obtener una cuenta nueva en nuestra comunidad. ¡Es fácil!

Registrar una nueva cuenta

Acceder

¿Ya tienes una cuenta? Conéctate aquí.

Conectar ahora

  • Explorando recientemente

    No hay usuarios registrados viendo esta página.

×